Missing packages from Diablo Extras

This page is to list the packages which are missing from extras-devel for Diablo and preventing the building of other packages.


[edit] Packages missing from Extras-Devel

Please add a comment below when you start working in a package, to avoid duplicated work.

You can also help listing here the problematic packages behind the most Missed applications.

[edit] Very Important Packages

Several packages depend on these ones:

  • libc-dev - Needed to install libncursesw5-dev
    • libc-dev is a virtual package.libc6-dev is in the diablo sdk repository and can be added easily. I doubt it will be added to extras. ~ qwerty12
  • libdb4.2 (4.2.52-18osso => 4.2.52+dfsg-2) - fails during system update, tried various "apt-get -f" with no luck
  • libxml2 (2.6.27.dfsg-1osso4 => 2.6.27.dfsg-1.maemo1) - fails during system update, tried various "apt-get -f" with no luck

[edit] The rest

  • Opensync packages (libopensync opensync-format-plugin-vformat msynctool opensync-plugin-file opensync-plugin-gpe libwbxml2 libopenobex libsyncml opensync-plugin-syncml) - These will be worked on later by Graham Cobb
  • Sisusb packages (sisusbvga sisbit xsisusb) - These will be worked on later by Graham Cobb

[edit] Fixed in extras-devel

Move here packages from the lists above once they are fixed in extras-devel.

  • GPE has been built.
  • libgnutls-dev - Needed to build: libsoup. Thanks to Ed (and all the other dependencies he also had to build!)
  • libsoup2.2-dev - Needed to build: GPE, Opensync. Thanks to Ed.

[edit] Packages missing from Extras

Obviously all the packages listed above are missing. In addition, the following packages are available in extras-devel but not available in Extras, preventing the installation of other packages from Extras.

  • libssl 0.9.7 In certified repository
    • Why is it needed at all, given that libssl 0.9.8 is in the core OS? Just to use chinook packages without rebuilding? --mgedmin 00:00, 2 July 2008 (UTC)
      • Indeed. A symlink suffices fine anyway. --qwerty12

[edit] Fixed in extras

Move here packages from the list above once they are fixed in extras.

  • grsync
  • libgtkhtml2-0.
  • libsoup2.2-dev and its dependencies (libtasn1-3, opencdk10, gnutls13, libgcrypt11, lzo2, libxml2). Graham Cobb promoted these (even though he did not upload them) because they are needed for GPE.
  • maemo-wordpy, maemo-periodic, python-gdata, python-flickrapi, mirage, python-gtkhtml2, nicotine, lybniz. They are in extras yet.
  • python2.5 + python2.5-dev - Needed to build several python applications. Thanks to Luciano and Lauro.
  • python2.5-gtk2 + python2.5-hildon. Without theses packages no hildonized python application will run.