Talk:USB networking

(axique) I tried to add a dummy devices on my N800 gconftool -s -t string /system/osso/connectivity/IAP/DEFAULT/type DUMMY but it does not show up in the connection list. I don't know how this syntax must be changed to archive this. (PS: feel free to remove this comment)

Dummy connections are broken in Diablo due to the new icd2 daemon -qwerty12


unmounting mmc cards when using usb networking

Is there some reason why there is umount /media/mmc1 umount /media/mmc2 in usb networking setup script? IMO it is perfectly possible to have mounted cards while using usb networking mode. --fanoush 19:56, 4 July 2008 (UTC)

Idem here I see no reason to unount the file systems --keesj 21:53, 4 July 2008 (UTC)

internet browsing via usb

Hi, I've set up everything and I have a successful USB connection (I even have a ssh access to my N900).

DNS seems ok too since I've made a routing (I've used IP-MASQUERADE-HOWTO).

I can ping for instance and I even managed to get the home page using wget

But the terminal doesn't use the USB connection when launching the browser from main MAEMO GUI.

Is it possible to choose the USB connection during the "internet connection selection" process instead of only Wifi or 3G ?

Current state of this "feature"

I have the patch for bug 3243 installed (via the recently-released Community SSU feature) on an N800 running OS2008. I have the USB Networking control panel installed; after running:

  • lsmod lists g_ether (alongside g_file_storage)
  • ifconfig lists the usb0 interface

The control panel window displays nothing but the "Setup" button; Refresh does nothing. Not clear how to uninstall this; I guess ifdown, then rmmod.

I also have the Advance Power Meter applet, which provides a switch between Host and OTG USB mode. With OTG selected, the N800 behaves as always when connected to the computer: the external cards are presented as storage devices.

With Host selected, on first connection, I was asked for a .INF file. I tried installing the "newer" .INF for the N900. Windows installed it with no complaint; however, the device did not show up in Windows' Hardware Manager -- until I selected "Show hidden devices". It doesn't appear in the Network Connections control panel.

When I try to uninstall (from Device Manager), I got: "Failed to uninstall device. The device may be required to boot up the computer." This was puzzling, until I found this Microsoft KB entry which explains how to show all the hidden entries; the driver can be uninstalled from the second, ghosted node.

Trying now to re-install on Windows using the older (770) .INF, but Windows is no longer noticing when the device is plugged in (in Host mode).

Set proxy

In the FAQ part of this page there is question: "My tablet can now talk to my XP machine, but how do I get out to the rest of the network?". It says just to edit the 'Dummy network' access point to add proxies. When I did this on my N900 I couldn't avoid entering a SSID for the 'Dummy network'. Now I aways get an error when switching to the dummy network because this SSID isn't found. How can I set the proxy without entering an SSID? It seems that the solution is to rerun "gconftool-2 -s -t string /system/osso/connectivity/IAP/DUMMY/type DUMMY" once the proxies have been set.

How do I set up DNS once I have connected the tablet and the host?

I did this differently on my N900. I added "resolv-file=/var/run/resolv.conf.usb0" at the end of /etc/dnsmasq.conf and the 2 following lines to /etc/network/interfaces in the "iface usb0 inet static" stanza:

	up echo nameserver > /var/run/resolv.conf.usb0
	up kill -SIGHUP `pidof dnsmasq`

This seems a more standard way of adding a namesaver to dnsmasq. I don't know if I should remove /var/run/resolv.conf.usb0 when I take the USB interface down. On the host in the "iface usb0 inet static", I added:

	up iptables -A PREROUTING -t nat -p udp -i $IFACE -d $IF_ADDRESS --dport domain -j DNAT --to-destination $(sed -ne '/^nameserver /{s///p;q}' /etc/resolv.conf)
	up iptables -A PREROUTING -t nat -p tcp -i $IFACE -d $IF_ADDRESS --dport domain -j DNAT --to-destination $(sed -ne '/^nameserver /{s///p;q}' /etc/resolv.conf)

to redirect the N900's dns queries to the correct nameserver. This avoids having to run a name server on my host.